Main

February 23, 2009

Youtube support was down

Last week there was an issue with youtube videos working. Originally I was using the link to the physical video file on their server. They don't like that happening for great reason, but it was the best solution for VideoANT since it relies so heavily on a custom timeline. Could you imagine having to use youtubes timeline for adding markers?

When they blocked the most recent method I was using to derive their video link I decided to further investigate their open API project and it turns out that they have finally released a chromeless version of their player sans any of their video controls. This is perfect for VideoANT because having multiple timelines would be confusing to users. I spent last week implementing their approved methods for supporting youtube video links so it should no longer randomly stop working. If anyone uses this updated version with youtube content and finds any errors or issues, please let me know!

November 12, 2008

Embed and Youtube are fixed and up!

Youtube videos are working again in VideoANT. Thanks for all of your patience during that fix! Remember that VideoANT is not vary accurate when using Youtube videos. This is due to the way Youtube compresses their videos. If you would like more accurate markers on the timeline with your video make sure to encode your own video files to post on your own server. They should always have the highest number of keyframes you can get away with and still have acceptable file size. I recommend at least one keyframe every 10 to 15 frames, but this should be adjusted depending on your needs along with the framerate your video is being encoded at.

**ALSO**
The embed player is now paused by default. Clicking anywhere on the video will start playback.

More changes to come soon... including proper play/pause functionality.

November 11, 2008

Youtube links failing

Youtube recently changed the API for how their videos are delivered to their players. This means that I have to find a way to get those videos to my player (VideoANT) as well. I thought I had it fixed, but they seem to keep making changes. I am working on it, but I wanted to let everyone know that it is going to be a few more days. Sorry for the inconvenience it may be causing you. I will make another post here when their links are working again.

April 16, 2008

BUG REPORT: large projects = fail for the Edit Page

Apparently there is a bug that causes the authoring page (the original VideoANT you set up) to begin slowing down after 25 to 30 massively large entries have been made. Keeping your entries short while I evaluate the cause will improve performance.

ADDITIONALLY...

Clicking EDIT in the email VideoANT sends you will cause a failure if the project is 25 to 30 entries or more, and their size is of any significance. I will make another post when I find out the cause, and provide an estimate for when the fix will go live.

I apologize for any work this effects.

February 14, 2008

HTML email issues

Hi everyone!

There has been a recent problem of VideoANT generated emails coming through sort of funky. If you have any issues with your emails please forward them to me. send them to: ant (at) umn . edu. Or, if you just feel like saying hello, send me an email and I will post user feedback, opinions, ideas, and concepts to share with the world!

January 31, 2008

Viewing link is broken (fixed)

UPDATE: The original blog post is still below, but the link is now fixed. If you have any troubles with following either link in your email please leave a comment below!

ORIGINAL POST: I have just noticed that the viewing link is broken. I will be looking at the reason first thing tomorrow to get things up and working again. I will post again when it is back up and running. Sorry for any setbacks this may have caused for anyone.

January 29, 2008

Broken links in email

Today I was notified by some testers that the email links VideoANT has been generating are incorrect. During the migration process the links were not updated to reflect the public URL. If you are experiencing bad links, simply delete “open/? from the address bar after you visit the broken link. Hit enter or “go? again to load the revised URL and everything should load correctly.

Bad email links

Today I was notified by some testers that the email links VideoANT has been generating are incorrect. During the migration process the links were not updated to reflect the public URL. If you are experiencing bad links, simply delete “open/? from the address bar after you visit the broken link. Hit enter or “go? again to load the revised URL and everything should load correctly.

Bad email links

Today I was notified by some testers that the email links VideoANT has been generating are incorrect. During the migration process the links were not updated to reflect the public URL. If you are experiencing bad links, simply delete “open/? from the address bar after you visit the broken link. Hit enter or “go? again to load the revised URL and everything should load correctly.

Bad email links

Today I was notified by some testers that the email links VideoANT has been generating are incorrect. During the migration process the links were not updated to reflect the public URL. If you are experiencing bad links, simply delete “open/? from the address bar after you visit the broken link. Hit enter or “go? again to load the revised URL and everything should load correctly.

January 28, 2008

Ordering ANTS by time

Currently, the list of annotations (ANTS) will not update order of entries after every change in the marker positions. I believe I know the cause, and will be looking into it in the next few days.